侧边栏壁纸
博主头像
Harry博主等级

沉迷学习,日渐消瘦

  • 累计撰写 16 篇文章
  • 累计创建 4 个标签
  • 累计收到 7 条评论
标签搜索

青龙面板脚本运行必须要安装的依赖

Harry
2022-01-05 / 3 评论 / 0 点赞 / 420 阅读 / 811 字
温馨提示:
本文最后更新于 2022-01-05,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。

青龙必须要安装的依赖

cd /ql/scripts
pnpm add -g pnpm
pnpm install -g
pnpm install -g js-base64
pnpm install -g ws
pnpm install -g date-fns
pnpm install -g ts-md5
pnpm install -g axios
pnpm install -g download
pnpm install -g fs
pnpm install -g child_process
pnpm install -g crypto-js
pnpm install -g crypto
pnpm install -g dotenv
pnpm install -g got
pnpm install -g http-server
pnpm install -g png-js
pnpm install -g qrcode-terminal
pnpm install -g request
pnpm install -g tough-cookie
pnpm install -g tslib
pnpm install -g tunnel
pnpm install -g md5
pnpm install -g jsdom
pnpm install -g silly-datetime
pnpm install -g form-data
python3 -m pip install --upgrade pip
pip3 install requests

或者在青龙面板直接添加下面代码

image.png

面板里安装的依赖

NodeJs下

crypto-js  
prettytable
dotenv  
jsdom
date-fns  
tough-cookie  
tslib
ws@7.4.3  
ts-md5  
jsdom -g  
jieba  
fs
form-data  
json5  
global-agent  
png-js  
@types/node  
require
typescript  
js-base64  
axios  

Python3下

requests
canvas  
ping3
jieba

Linux下

bizCode
bizMsg  
lxml
0

评论区